Home  |  Forums  |  Downloads  |  Gallery  |  News & Articles  |  Resources  |  Jobs  |  FAQ  |  SearchSearch  |  Join  |  LoginLogin

Welcome !

196 Users Online (43 Members): Show Users Online - Most ever was 626 - Mon, Jan 12, 2015 at 2:00:17 PM



Forums >> Revit Building >> Technical Support >> Revit-Autocad Import/Cad Resolution problems

Search this ThreadSearch this Thread | Page 1 of 1 |

Tue, Oct 23, 2007 at 6:46:03 PM | Revit-Autocad Import/Cad Resolution problems




Joined: Thu, Jan 25, 2007
6 Posts
No Rating

Hi all,

I'm trying to import a site plan from Autocad 2008 into Revit and am having some really strange behavior.  The imported file's resolution is terrible and changes depending on the zoom level of my screen.  I've tried changing everything I can think of with no success. 


See the attached file for a quick example - look at the (supposed) circles around the're seeing the same exact area - one image is slightly zoomed in from the second.  File is a normal Autocad vector file and displays perfectly there.  If I query one of the pieces of linework, the "highlighted" geometry shows up normally, so it seems to be a display issue.  I also tried plotting and it plots as it displays....

Any ideas?

Thanks in advance....


Attached Images


This user is offline


Thu, Mar 19, 2009 at 4:54:18 AM | Revit-Autocad Import/Cad Resolution problems




Joined: Thu, Aug 10, 2006
3 Posts
No Rating

I am getting an identical problem with importing a CAD file into my Revit file.

Does anyone know how to resolve this problem as I require accurate CAD import to place my model too.

This user is offline


Thu, Mar 19, 2009 at 5:32:14 AM | Revit-Autocad Import/Cad Resolution problems


Mr Spot

site moderator|||
Mr Spot Avatar

Joined: Tue, Jan 13, 2004
2889 Posts
4.5 Stars: 92 Votes

Sounds like the 2 mile error...  If the co-ordinates of the imported file are a long way from the origin then there is a truncation error that occurs causing the lines to display strangely.

Everything you draw in Revit needs to be located with an imagine 2 mile diameter (1.6km radius) circle around 0,0 to avoid this issue.  Try editing your DWG file to reset 0,0 to a localised point near all the detail.






Co-Founder | BIM Consultant | Software Designer  CryingB. Arch)

Xrev Revit API Addins | Revit Rants

This user is offline

View Website

Thu, Mar 19, 2009 at 11:40:22 AM | Revit-Autocad Import/Cad Resolution problems




Joined: Thu, Jan 25, 2007
6 Posts
No Rating

Mr. Spot is correct....get everything closer to 0,0 and it should work - at least it did for me.

This user is offline


Tue, Aug 4, 2009 at 9:35:44 PM | Revit-Autocad Import/Cad Resolution problems




Joined: Sun, May 13, 2007
1 Posts
No Rating

This kind of crap happens to me ALL the time importing AutoCAD into Revit.  And its happened in both 2009 and 2010.  We've tried a million ways to resolve the issue.  I've exploded the .dwg, flattened it, copied and pasted it into a fresh file, bound it, saved it as different file formats (old acad or dxf), and I've tried this "2 mile solution."  Importing vs linking... no difference.  Nothing works. 

The latest way that Revit is trying to push me into an early grave is that I've gotten the imported .dwg to stop jumping around and looking all wonky... or so I think.  But upon closer inspection, bizarre shifts in the positions of lines have occurred, which means I can't line up the .dwg with the revit file, or trust any positions of lines in the .dwg even if i think i have it aligned. 

5 1/2 years of architecture school... to sit behind an computer screen all day and exercise my finger.  That was a great investment.

This user is offline

View Website

Wed, Aug 5, 2009 at 12:03:35 AM | Revit-Autocad Import/Cad Resolution problems



dgcad Avatar

Joined: Fri, Mar 18, 2005
1231 Posts
3.5 Stars: 34 Votes

My spider senses (and 20 years of the DWG) are telling me that something in that civil file if off on mars. It would not be the first time. In fact it's the norm. Who knows the history of that file and how many unskilled hands have been into it.


A frozen / off point or node in a nested block etc. etc. Just because you copy and paste to a new file does not mean that something you selected does not have an entity that is on a layer that is off or frozen that is far away. Civil files are imfamous for having phanton objects off in space. It can drive a man to drink !


As an experiment do this.

Open the DWG file in AutoCAD that you already cleaned up, flattened and purged

SAVEAS a new name

in model space, thaw and turn on every single layer and then regenerate

explode everything (use the 'ALL' selection method) until there is nothing left to explode and then explode once more just in case

then do a zoom extents

See what you get ! If you see nothing there's your clue.


Chances are something is WAY out there. Then you need to find the phantom objetc(s) identify what it (they) belongs to and fix the problem.


This is an interesting predicament because if this is the case you will need to have expert AutoCAD skills to actually solve a REVIT problem. As in, if the experiemnt above does prove there are 'far away objects' that only explains the behavour in REVIT but then the work begins to actually resolve the DWG problem. So then I would conclude that each architectural office, even if 100% REVIT based, still needs to have a resident DWG expert on hand. And I mean expert, not a novice user.

Expert RVT + Expert DWG = $$ . . . . I suppose 5 1/2 years of Architectural Education is probably worth something too : )

Edited on: Tue, Aug 4, 2009 at 7:32:50 PM



FULL 'DOWNLOAD ACCESS' to all 850+ CADclips videos for only $150


This user is offline

View Website

Tue, Aug 11, 2009 at 7:57:20 PM | Revit-Autocad Import/Cad Resolution problems



jhayden Avatar

Joined: Tue, Mar 17, 2009
32 Posts
No Rating

I'm having the same '2 mile radius' error. I've gone to several posts and done everything they suggested (purging, audit, layers on/thawed, explode multiple times, zoom extents, flatten, wblock, set orgin to manaul-center, custom insertion units, relocate dwg to 0,0) and I still get the error message. Any final tips or suggestions?

This user is offline


Tue, Aug 11, 2009 at 9:06:54 PM | Revit-Autocad Import/Cad Resolution problems




Joined: Fri, Jun 12, 2009
157 Posts
4 Stars: 5 Votes

How about changing your VIEWRES to 10,000 rather than 1000? not sure if that's for display only. and make sure you SHADEMODE (command: sha) is set to 2dwireframe and not in Realistic. Just a thought. I could be wrong.


 "If you tell the truth, you don't have to remember anything"

This user is offline

View Website

Search this ThreadSearch this Thread | Page 1 of 1 |

Similar Threads

Thread/Thread Starter


Last Post


Autocad Import Problems

Revit Building >> Technical Support

Tue, May 5, 2009 at 6:55:33 PM


CAD import resolution

Revit Structure >> Technical Support

Fri, Aug 1, 2008 at 4:22:45 PM


Image Import Problems

Revit Systems >> Technical Support

Tue, Jun 5, 2007 at 5:21:01 PM


Autocad import problems

Revit Building >> Technical Support

Thu, Jan 20, 2011 at 7:54:38 AM


Importing (civil) CAD in Revit

Revit Building >> Technical Support

Tue, Jul 10, 2012 at 12:12:30 AM


Site Stats





Forum Posts:


Job Listings:


Sponsored Ads

Home | Forums | Downloads | Gallery | News & Articles | Resources | Jobs | Search | Advertise | About | Link To Us | Site Map | Member List | Firm List | Contact Us

Copyright 2003-2010 Pierced Media LC, a design company. All Rights Reserved.

Page generation time: 6.7544


User Name:


Remember Me  

Forgot Password?

Search Forums

Advanced Search

Search Forums

Advanced Search

Clear Highlights

Clear Highlights