RevitCity.com Logo

Home  |  Forums  |  Downloads  |  Gallery  |  News & Articles  |  Resources  |  Jobs  |  FAQ  |  SearchSearch  |  Join  |  LoginLogin

Welcome !

431 Users Online (232 Members): Show Users Online - Most ever was 626 - Mon, Jan 12, 2015 at 2:00:17 PM

 

Forums

Forums >> General Discussion >> Revit Project Management >> Linked CAD files are not turning off

Search this ThreadSearch this Thread | Page 1 of 1 |

Thu, Feb 18, 2016 at 1:59:51 PM | Linked CAD files are not turning off

#1

jasonium


active

Joined: Wed, Apr 22, 2015
0 Posts
No Rating


In Revit Architecture 2016, I am linking an AutoCAD file. Everything is working as expected until:

I go to manage links and unload the dwg. Now when I switch views portions of the CAD file are visible (such as wiring lines in one view, text in another etc). The only way to get rid of it is to delete the linked file. 

This is happening with a myriad of cad files from in house to those sent by consulants - xrefs are bound and the files are saved as dwg version 2013.


This user is offline

 

Thu, Feb 18, 2016 at 6:48:28 PM | Linked CAD files are not turning off

#2

WWHub


site moderator|||

Joined: Tue, May 16, 2006
13079 Posts
3.5 Stars: 361 Votes


If this is a real issue, I have not seen it or heard about it yet.   A am still assuming there is a process error here because I have problems with your terminology.   You load/unload links and you can remove links.  You delete file imports.  I think you may have had both.

 

So, I suggest you look at the following:

 

Do you know that you do not have to unload a file to turn it off.  These can be controlled in VG turning the file off/on or any layers off/on.


This user is offline

 

Thu, Feb 18, 2016 at 8:30:34 PM | Linked CAD files are not turning off

#3

jasonium


active

Joined: Wed, Apr 22, 2015
0 Posts
No Rating


This issue has our trainer stumped as well, so I'll try to do this step by step. 

 

I link a cad file into the first floor plan view. As long as it is linked, it shows up in other views as expected. 

 

I now UNLOAD the cad file and, as expected, it is no longer visible in the firs floor plan view. When I go to any other view, portions of the CAD file are still visible. The only way to fully remove it is to UNLOAD the CAD file. 

 

Revit Architecture 2016, SP2. 


This user is offline

 

Thu, Feb 18, 2016 at 8:49:32 PM | Linked CAD files are not turning off

#4

WWHub


site moderator|||

Joined: Tue, May 16, 2006
13079 Posts
3.5 Stars: 361 Votes


Look at what you wrote ... You unloaded it twice?

 

When you link a CAD file, there is an option checkbox for "CURRENT VIEW ONLY".   If you check that box, the item will only show in that view and it will be 2D even if the CAD is 3D.   If you don't check that box the CAD is inserted at the level of the plan and will be 3D even if it is only 2D.   The 2D CAD will show up in 3D views at the level it was inserted (linked) on.  This is all the same for inserted vs linked CAD.

 

BTW - Things must have changed and I was in error earlier.   You can delete a CAD link which really does remove the link.

 

I do not have 2016 up now to see if this is a 2016 problem.  It is not a problem in earlier versions.   Do you have all of the updates installed?   There are quite a few!


This user is offline

 

Thu, Feb 18, 2016 at 10:00:56 PM | Linked CAD files are not turning off

#5

jasonium


active

Joined: Wed, Apr 22, 2015
0 Posts
No Rating


I did say Unload twice. My mistake. 

Once the CAD file is unloaded the first time, go to the second floor plan view and you will still see the CAD file. This was not brought in specific to the view. Even after unloading it, by going to visibility graphics and turning off the CAD in the import tab, it still shows up. THe only way to hide it is by element or by selection set and hide it by filters. 

 

We just tested this on 2015 and the problem does not exist, so this is only occurring in 2016, fully updated. 


This user is offline

 

Wed, Apr 27, 2016 at 1:04:44 PM | Linked CAD files are not turning off

#6

ruudvgool


active

Joined: Wed, Mar 16, 2016
0 Posts
No Rating


I have the same thing in Revit16. Unload greys it out but shows it in drawings/prints. Remove only gets rid of it. I understand one can use Visibility/Filters, but why does it show the cad when it is even unloaded?! I use the cad as a base to draw on, and just want to unload it when I'm done.. Weird it doesn't.


This user is offline

 

Thu, May 5, 2016 at 4:58:26 PM | Linked CAD files are not turning off

#7

FE023


active

Joined: Mon, Jul 21, 2014
0 Posts
No Rating


Hi,

Any news on this?

I have the exact same behavior.

was teaching a class and virtually everyone could replicate this behavior.

 

The only way to make this "linked dwg ghost" disapear from some views after unloading it, was either removing it, or disable all their layer in VG

 

Thanks

Francisco


This user is offline

 

Sun, May 8, 2016 at 10:26:25 AM | Linked CAD files are not turning off

#8

Beaucoupnice


active
Beaucoupnice Avatar

Joined: Mon, Nov 19, 2007
93 Posts
3.5 Stars: 6 Votes


There are 2 ways to bring in a CAD file, import and link. Link gives you the ability to unload and load a linked cad file outside of Revit. Import just brings the cad file in with no ability to unload or load it. It sounds like you imported it in.

Use an addin like ideate explorer to see all the dwgs files in your revit model.

Delete them all and link in the right cad file using link tool.

Generally AutoCAD files and Revit hate each other. So I do anything I can to avoid having a dwg file in my model. The best workflow is to clean up the AutoCAD file in Autocad by deleting all extranneous stuff putting eveything on a single layer, importing it into an empty revit model. Exploding it. Changing everything to right linetypes, fonts etc and then puring it. Copying it across to your actual Revit model as Revit content.More importantly is just trying to do everything in Revit. Sod AutoCAD. Its old school and just makes more work for everyone.


-----------------------------------

__________I'm the guy they come to when they didn't follow my recommended workflows.__________

This user is offline

 

Sun, May 8, 2016 at 5:15:53 PM | Linked CAD files are not turning off

#9

FE023


active

Joined: Mon, Jul 21, 2014
0 Posts
No Rating


@Beaucoupnice

 

Everybody in the thread specifically refers to "link" or "unload" (not to mention  the thread tittle)  thus ruling out the scenario you're suggesting.

 

Thanks anyway.

 



Edited on: Mon, May 9, 2016 at 4:52:46 AM

This user is offline

 

Thu, May 12, 2016 at 7:52:57 PM | Linked CAD files are not turning off

#10

hlynchNPI


active

Joined: Tue, Jun 2, 2015
0 Posts
No Rating


Have the same problem, cad files are linked and not imported, when I underlay a view looking up or down the ghost of the linked file shows up even when it's unloaded.


This user is offline

 

Thu, May 12, 2016 at 8:12:07 PM | Linked CAD files are not turning off

#11

WWHub


site moderator|||

Joined: Tue, May 16, 2006
13079 Posts
3.5 Stars: 361 Votes


Someone that has this issue that is on subscription should send it to autodesk.

 

You might also try the autodesk support forum.


This user is offline

 

Fri, May 13, 2016 at 12:47:07 PM | Linked CAD files are not turning off

#12

hlynchNPI


active

Joined: Tue, Jun 2, 2015
0 Posts
No Rating


Thanks, I asked the question here:

https://forums.autodesk.com/t5/revit-architecture/linked-cad-file-remains-displayed-even-when-link-is-unloaded/td-p/6324819

 


This user is offline

 

Fri, Jun 17, 2016 at 2:45:09 PM | Linked CAD files are not turning off

#13

Rigter


active

Joined: Sat, Jun 16, 2012
0 Posts
No Rating


I've got the same problem.

I turned it off by turning off the Workset it's placed on.

Of course I have to do this for every view it's in when not linked to the same View Template. Very annoying.

 


This user is offline

 

Fri, Jun 17, 2016 at 6:12:03 PM | Linked CAD files are not turning off

#14

hlynchNPI


active

Joined: Tue, Jun 2, 2015
0 Posts
No Rating


If you go to the link I posted in my message prior, Autodesk support responded that they are working on this issue. It is currently unresolved and your used of worksets is the work around they're currently touting.


This user is offline

 

Tue, Nov 29, 2016 at 9:31:28 PM | Linked CAD files are not turning off

#15

wendyceron


active

Joined: Sat, Feb 19, 2011
0 Posts
No Rating


I am having the same issue in Revit 2016. I even have the linked file on a CAD workset, turned off the workset, and the drawing still shows up in Underlay. I checked the Autodesk forum on this issue and it still doesn't seem to have been resolved. Has anyone heard otherwise?

 

https://knowledge.autodesk.com/support/revit-products/troubleshooting/caas/sfdcarticles/sfdcarticles/Revit-unloaded-DWGs-visible-in-underlay.html


This user is offline

 

Search this ThreadSearch this Thread | Page 1 of 1 |



Similar Threads

Thread/Thread Starter

Forum

Last Post

Replies

Export from Revit To CAD with RELATIVE linked files

General Discussion >> Revit Project Management

Wed, Nov 29, 2017 at 5:00:35 PM

0

linked cad files accross projects

Revit Building >> Technical Support

Tue, Oct 30, 2007 at 2:30:07 PM

0

Constraining to linked CAD file

Revit Building >> Technical Support

Thu, Apr 4, 2013 at 8:09:14 AM

2

revit freezing and not responding when cad file linked

Revit Building >> Technical Support

Fri, Feb 6, 2015 at 5:24:56 PM

5

Revit Project Managment of Linked and Imported files

General Discussion >> Revit Project Management

Mon, Sep 12, 2016 at 4:39:14 PM

2

Site Stats

Members:

1531746

Objects:

21320

Forum Posts:

151323

Job Listings:

3

Sponsored Ads

Home | Forums | Downloads | Gallery | News & Articles | Resources | Jobs | Search | Advertise | About RevitCity.com | Link To Us | Site Map | Member List | Firm List | Contact Us

Copyright 2003-2010 Pierced Media LC, a design company. All Rights Reserved.

Page generation time: 0.4830

Login

User Name:

Password:

Remember Me  

Forgot Password?

Search Forums

Advanced Search

Search Forums

Advanced Search


Clear Highlights


Clear Highlights