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Parametric Component Design
Techniques

1

In this tutorial, you create a new parametric component within the Family Editor. During this tutorial, you learn
the process and methodology of creating a new family. In exercises that become increasingly complex, you learn
specific techniques and best practices that you can apply broadly when creating other families in Autodesk Revit
Building.
The parametric component that you design in this tutorial is an open-joist wood floor truss. In this case, the length
of the trimmable truss determines the size and grade of the truss chords. In the center of the truss is a mechanical
service clearance to accommodate HVAC systems. The truss also has multiple types, formula-based parameters,
assigned subcatecories, and detail level controls. This type of component uses a broad spectrum of design techniques
within the Family Editor.

The goal of this tutorial is to teach you the proper approach to parametric component creation, not specifically
how to make a floor truss. At the end of this tutorial, you will understand the process, methodology, and the
specific techniques for creating a parametric component.

1

Planning a Parametric Component Family
Creating a new parametric component family is no different than any other design process; planning ahead is one of
the most important steps. Knowing why you are creating a particular family and what you need it to do will drive the
specific design process. In this lesson, you accomplish two main tasks: you determine the component needs and select
the family template that is suited to those needs.

Determining Component Needs
In this exercise, you determine the requirements of the new component. In this case, it is an open-joist wood floor
truss. For training purposes, imagine that your firm specializes in light commercial and residential design. Your
assignment is to create a truss that adapts parametrically to changes in the building design.

Decide component type and design requirements
1 What type of component are you designing?
In this case, the design spec requires that the floor truss snaps to columns, beams, and structural walls, and also
works intuitively with them. It should also be an available option within a beam system. In addition, the component
should use the point-to-point insertion method with the joist web members adjusting parametrically.
Because this component has to interact closely with other structural components, this must be a structural beam
component. This decision dictates which family template you begin with. If the component did not have to interact
so closely with other structural components, a generic floor-based component might work. Although this solution
is possible, it is not the best solution.
In the next exercise, you select the best available template with which to begin the new structural beam family.
2 What additional design requirements affect the design plan for this beam family?
■

The truss should automatically adjust depth as the length changes.

■

Two types should be created, a 2x3 truss and a 2x4 truss.

■

A rectangular mechanical clearance opening must be centered within the beam.

The design requirements dictate how simple or complex a family must be. In this case, the beam design must be
advanced in order to have the flexibility that the specs require.

NOTE When creating a new family, you should avoid over-designing the component. If the design requirements can
be met with a simple design, then you should design only what is needed to satisfy the requirements. For every complexity
added to a family, there is a computing performance cost that must be paid within the project. Take this into consideration
during your design planning.

Using the new family within a project
3 How will you use the family within a project?
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■

What materials need the most control?
These materials, such as wood type, would require Instance or Type parameters.

■

What materials remain constant throughout a project?
The chord and web material will always be wood. These materiails can be applied using Object Styles.

■

What types are most commonly used?
In this training case, only the 2x3 and 2x4 trusses with wood web members are required.

■

How will the component need to be scheduled?
This is an important question, especially if you are going to be nesting subcomponents that may require
separate scheduling. In addition, the means in which to gather the information you require within the schedule
needs to be built into the component.

You have completed the planning stage for the new family. Depending on the family you are designing, the
planning stage and questions may differ.
4 Continue with the next exercise, Selecting the Family Template.

Selecting the Family Template
In this exercise, you determine which family template provides the best starting point for the new beam family. In the
previous exercise, you determined that the component type is a structural beam. This critical decision reduces the
quantity of template options.
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Review the template options
1 Close any open projects or families.
2 Click File menu ➤ New ➤ Family.
The New dialog box opens to the templates folder that is specified in your Settings ➤ Options dialog box. You
should be in the Imperial Templates folder. If you are not in this folder, navigate to it.
3 In the New dialog box, scroll through the various template options.
Notice that most of the template names include the component type. In addition, the template name often includes
information how the component would be used with a project, for example: wall based or floor based.
4 In the New dialog box, select Generic Model floor based.rft.
NOTE Do not double-click the template or open it. Select it so that the preview displays.
On the right side of the New dialog box, notice the preview.

Like most generic family templates, it provides two intersecting reference planes: Center (left/right) and Center
(front/back).
5 In the New dialog box, scroll to the structural framing templates.
There are two structural framing templates provided.
■

Structural Framing - Beams and Braces.rft
This template is design specifically to accommodate point-to-point insertion and the specific snapping, spacing,
and display functions required by structural beams.

■

Structural Framing - Complex and Trusses.rft
This template is designed for complex framing components and trusses. It provides two intersecting reference
planes: Center (left/right) and Center (front/back). Because of its simplicity, it is not designed to create a
component capable of point-to-point insertion.

6 Select Structural Framing - Complex and Trusses.rft, and notice the preview.

Although the template name suggests this is the appropriate template, it is not the best starting point for the beam
family.
7 Select Structural Framing - Beams and Braces.rft and notice the preview.

Notice this template offers three horizontal planes on each side of the center (left/right) reference plane. These
planes are designed specifically to accommodate point-to-point beam insertion and the special snapping and
display requirements of beam components. This template is the best starting point for the new family.
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NOTE Although this is the template you use to start the tutorial, do not open this template. For training purposes, this
template resides within the training folders and should be opened from there.

Open the family template
8 In the left pane of the New dialog box, click the Training Files icon.
9 Open Structural Framing - Beams and Braces.rft located in the Imperial ➤ Templates folder.
10 Maximize the view, Floor Plan: Ref. Level.

In this view, you can see the rectangular beam extrusion and a symbolic line.
11 In the Project Browser, under Elevations, double-click Front.
Notice that the beam extrusion is centered on the level line. When a beam family based on this template is added
to a project, the top of the beam extrusion is aligned to the associated level of the plan view.
12 In the Project Browser, under 3D Views, double-click View 1.

This beam extrusion is supplied within the template as a starting point. Like many templates, the geometry supplied
can be used or discarded as needed.
13 Proceed to the next lesson, Creating the Component Skeleton.

Creating the Component Skeleton
In this lesson, you add the reference planes, lines, and dimensions that provide a skeleton for the solid geometry. As
you add solid geometry later in the tutorial, you snap and lock the solid geometry to these reference planes and lines.
Therefore, creating a skeleton to build upon is the foundation of a new component family.
NOTE When creating or modifying a family, it is not necessary to create a skeleton of reference planes or lines and then align
and lock the solid geometry to it. Dimensioning the solid geometry directly also works; however, using reference planes and
lines is considered more reliable and is therefore a best practice.
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Adding Reference Planes
In this exercise, you add reference planes to the beam design. These reference planes act as part of the skeleton to which
the solid geometry will align and lock.

Dataset
Continue to use the dataset you started in the previous exercise.

Review existing reference planes
1 In the Project Browser, under Floor Plans, double-click Ref. Level.
2 Place the cursor over the leftmost vertical reference plane until the tooltip displays the name of the plane, Reference
Plane: Left.
TIP The name also displays on the Status Bar.
3 Repeat this step for the other two vertical planes on the left side.
The reference planes in this template are designed to accommodate the point-to-point insertion of a beam
component. The reference planes and their respective explanations are listed below.
■

Left and Right:
These two planes mark the points where the beam intersects with other columns. In the image below, two
steel columns and a steel beam have been added to a project. The two arrows point to the snap points that
the left and right reference planes refer to.
NOTE The reference planes shown in the project image below were added as a training reference. Reference planes
that display within a family file do not display within a project.

■

Member Left and Member Right:
These two planes refer to the left and right extent of the beam solid geometry when displayed in a medium
or fine display view of a project. In the project plan view image below, notice the location of the beam extents.
The six reference planes shown in the project below were added as a training reference; they do not display
when the family is loaded into a project.
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■

Stick Symbol Left and Stick Symbol Right:
These two planes refer to the extents of the stick symbol when it is loaded into a project and the plan view
display setting is coarse.

Each family template has a different set of reference planes established within it. Before adding new reference
planes, it is important to be familiar with the template so you do not create duplicate or conflicting planes.

Delete existing solid geometry
4 Select the rectangular beam extrusion.
NOTE Be careful not to select the symbolic line.

5 On the Edit Toolbar, click

.

In a later exercise, you add the solid geometry for the truss as a sweep.

Add new reference planes
6 On the Design Bar, click Ref Plane.
7 Add a reference plane approximately 2” above the horizontal reference plane: Center (Front/Back).
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8 Add a reference plane approximately 2” below the horizontal reference plane: Center (Front/Back).

You will use these two reference planes to control the beam width and keep it centered on the reference plane:
Center (Front/Back).

Add ref. planes to control beam depth
9 In the Project Browser, under Elevations, double-click Front.
10 On the Design Bar, click Ref Plane.
11 Add a reference plane approximately 6” below the Level: Ref. Level.

12 Add a reference plane approximately 6” above the Level: Ref. Level.
TIP You can also use the mirror tool to accomplish this task. To do this, select the lower horizontal reference plane, click
on the Edit toolbar, and select the Level: Ref. Level as the mirror axis.
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These two reference planes mark the top and bottom extents of the beam. This beam requires additional reference
planes to complete the truss skeleton.
13 On the Design Bar, click Ref Plane.
14 On the Options Bar, click

, and specify an Offset of 0' 1 1/2”.

The next four reference planes that you add mark the thickness of the truss chords.
15 Place the cursor over the top horizontal reference plane. When a copy of the reference plane displays below it,
click to place it.
TIP You can control the direction of the offset by moving the cursor slightly to either side of the line you intend to pick.

16 Place the cursor over the lower horizontal reference plane and when a copy of the reference plane displays above
it, click to place it as shown.

17 Place the cursor over Reference Plane: Member Left, and when a copy of the reference plane displays to the right
of it, click to place it as shown.

18 Place the cursor over Reference Plane: Member Right, and when a copy of the reference plane displays to the left
of it, click to place it as shown.
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You have completed the reference planes that make up the skeleton of the chords. Before you move on to the next
exercise, you must add four additional reference planes to accommodate the center chase.
19 On the Options Bar, specify an Offset of 0' 8”.
20 Place the cursor over Reference Plane: Center (Left/Right), and when a copy of the reference plane displays to the
left of it, click to place it as shown.

21 Place the cursor over Reference Plane: Center (Left/Right), and when a copy of the reference plane displays to the
right of it, click to place it as shown.

22 On the Options Bar, specify an Offset of 0' 9 1/2”.
23 Use the Reference Plane: Center (Left/Right) to add reference planes to the left and right of it as shown below.
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24 In the Project Browser, under Floor Plans, double-click Ref. Level.
Notice the reference planes that you added in the elevation view. Although there is nothing technically incorrect
regarding the reference planes in this view, cleaning up some of the extents would make the view easier, which
you do in the next exercise.

25 On the Design Bar, click Modify.
27 Click File menu ➤ Save.
28 In the Save As dialog box, enter Wood Floor Truss for File name, navigate to the folder of your choice, and click
Save.
NOTE You use this family for the remainder of this tutorial. Make sure you remember where you saved it.
29 Proceed to the next exercise, Adding Dimensions and Constraints.

Adding Dimensions and Constraints
In this exercise, you add some of the dimensions and constraints that control how the open web floor truss adapts to
changes in its geometry. By applying dimensions and constraints directly to the skeleton of the family, you can make
sure the new family adapts to changes in geometry as expected before adding solid geometry to it.

Creating the Component Skeleton | 11

Dataset
Continue to use the dataset, Wood Floor Truss.rfa, that you saved at the end of the previous exercise.

Dimension chord width
1 On the Design Bar, click Dimension.
2 On the Options Bar, click

.

This tool is the aligned dimension tool. It allows you to dimension between parallel lines.
3 Select each of the horizontal reference planes and place the dimension to the left as shown. After adding the
dimension, separate the overriding values by dragging the value controls as shown.
TIP You may need to adjust your zoom settings during this procedure.

4 On the Design Bar, click Modify.
5 Select the dimension you added in the previous step, and click the EQ symbol when it displays.
This ensures that changes to the chord width are distributed equally across the center reference plane.
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6 On the Design Bar, click Dimension.
7 Add a dimension referring to the upper horizontal reference plane and the lower horizontal reference plane. Place
the dimension as shown.

Add the depth dimension and equality constraint
8 In the Project Browser, under Elevations, double-click Front.
9 On the Design Bar, click Dimension.
10 Select the upper horizontal reference plane, the Center reference plane, and the lower horizontal reference plane,
place the dimension to the left as shown, and click the EQ symbol to apply the equality constraint.
NOTE The center horizontal reference plane overlaps the level line: Ref. Level. You may need to use the TAB key to
toggle the selection to the reference plane.

11 Add a dimension referring to the upper horizontal reference plane and the lower horizontal reference plane and
move it to the left of the equality constrained dimension you added previously.
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Dimension and constrain the center chase width
12 Add a dimension referring to the three vertical reference planes in the center of the model, place the dimension
under the lines as shown and click the EQ symbol to apply the equality constraint.

13 Add a dimension referring to the reference planes to the left and right of the Center (Left/Right) reference plane,
and place it below the dimension you added previously.

Dimension chord thickness
14 On the right side of the model, add two dimensions as shown.
These dimensions refer to the chord thickness.
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15 Add four dimensions as shown.
These dimensions refer to the chord thickness of the vertical members and the members that border the center
chase.

You have finished adding the dimensions and constraints that control how the truss skeleton adapts to changes.
Throughout the tutorial, you will add additional reference planes, dimensions, and constraints as needed.
In the next exercise, you label the dimensions to create instance and type parameters. These parameters are the
key to providing flexibility within a project. In addition, they allow you to “flex” the model in order to test your
design.
16 Click File menu ➤ Save.
17 Proceed to the next exercise, Creating New Length Parameters.

Creating New Length Parameters
In this exercise, you create new length parameters that control the basic dimensions of the floor truss. The parameters
that you create when designing a family are the same parameters used within a project to control the instance and type
parameters of that family. When you design a new family, it is important to decide how much control over the
component will be required after the component is loaded into a project.
There are many types of parameters and various ways to create them. In this exercise, you label the dimensions that
you added in the previous exercise. When you label a dimension in the Family Editor, it becomes a parameter. You
choose whether to make it an instance or type parameter.

Things to consider when deciding “instance” or “type:”
■

If the component comes in standard sizes that must be maintained, consider making it a type parameter.

■

If the component is something that is cut or otherwise extremely flexible, consider making it an instance parameter.

■

If the component has material that varies per component, consider making the material parameter an instance
parameter.

■

If the parameter controls something that usually remains constant by its nature, consider making it a type parameter.
You should lean towards simplicity whenever possible.
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Dataset
Continue to use the dataset, Wood Floor Truss.rfa, that you saved at the end of the previous exercise.

Create the chord width parameter
1 In the Project Browser, under Floor Plans, double-click Ref. Level.
2 Select the dimension that refers to the width of the chord as shown.

3 On the Options Bar, select Add parameter for Label.
4 In the Parameter Properties dialog box, do the following:
■

Under Parameter Type, select Family parameter.

■

Under Parameter Data, enter Chord Width for Name.

■

Select Dimensions for Group parameter under.

■

Select Type.
This indicates whether the parameter is a type or instance parameter.

■

Click OK.

Create truss depth parameter
5 In the Project Browser, under Elevations, double-click Front.
6 Select the dimension on the left that refers to the depth of the truss.

7 On the Options Bar, select Add parameter for Label.
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8 In the Parameter Properties dialog box, do the following:
■

Under Parameter Type, select Family parameter.

■

Under Parameter Data, enter Depth for Name.

■

Select Dimensions for Group parameter under.

■

Select Type.

■

Click OK.

Create center chase width parameter
9 Select the dimension that refers to the width of the center chase interior.

10 On the Options Bar, select Add parameter for Label.
11 In the Parameter Properties dialog box, do the following:
■

Under Parameter Type, select Family parameter.

■

Under Parameter Data, enter Center Chase Width for Name.

■

Select Dimensions for Group parameter under.

■

Select Type.

■

Click OK.
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Create chord thickness parameter
12 On the right side of the model, select the dimension that refers to the thickness of the lower horizontal truss chord
as shown.

13 On the Options Bar, select Add parameter for Label.
14 In the Parameter Properties dialog box, do the following:
■

Under Parameter Type, select Family parameter.

■

Under Parameter Data, enter Chord Thickness for Name.

■

Select Dimensions for Group parameter under.

■

Select Type.

■

Click OK.

TIP You may need to drag the text label downward as shown.

Apply chord thickness label to other dimensions
15 On the right side of the model, select the dimension that refers to the thickness of the upper horizontal truss chord.
16 On the Options Bar, select Chord Thickness for Label.
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17 Apply the Chord Thickness label to the vertical chords and the vertical members on the left and right side of the
center chase as shown.

18 On the Design Bar, click Family Types.
In the Family Types dialog box, notice the labelled dimensions display under the list of parameters and under the
group, Dimensions.
When you load this family into a project, these parameters will be available within the Type Properties dialog box
for the beam.
19 Click Cancel.
20 On the File menu, click Save.
21 Proceed to the next exercise, Flexing the Component Model.

Flexing the Component Model
One of the most important steps in the process of creating a new parametric component is the flexing of the model.
Flexing the model means to change parameter values, thus forcing the model to adapt to the changes. This is not
limited to length parameters. If you add a new material parameter, you should also test it to make sure it works as
expected. You should flex the model after any major change to the design.
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You should flex a new family after:
■

Adding or modifying an element.

■

Adding or modifying a parameter.

■

Adding a new constraint.

■

Nesting a component.

■

Adding or modifying a parameter formula.

When you flex a family, you should always do it from the Family Types dialog box, rather than by manually stretching
or manipulating the objects within the family. When you change a parameter value and apply the change, this is the
most accurate way of testing how the family will behave within a project.

In this exercise, you flex the model to test the various length parameters that you added in the previous exercise. Even
though you have yet to add any model geometry to the family, it is important to verify that the reference lines adjust
to changes as constraints are maintained. After you verify this, you can add the model geometry to the skeleton and
be relatively certain that it will also flex as expected.

Dataset
Continue to use the dataset, Wood Floor Truss.rfa, that you saved at the end of the previous exercise.

Preparing the family for flexing
1 When flexing the model, you need to be able to see the model within the drawing area and also apply new values
within the Family Types dialog box:
■

Maximize the Revit window and adjust the zoom settings so the model is in one corner of the drawing area.
When you open the Family Types dialog, you can drag it to the opposing corner.
or

■

Reduce the Revit window and keep the model centered in the drawing area. When you open the Family Types
dialog box, you can drag it off the Revit window as shown.

Adjust your display using one of the two methods before opening the Family Types dialog box.
2 On the Design Bar, click Family Types, and drag the dialog box so that you can view the model.
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Flex the truss depth
3 In the Family Types dialog box, under Dimensions, enter 2' 0” for Depth, and click Apply.
Notice the depth of the truss adapts to the change in dimension value. Also notice the equality constraint spreads
the additional depth evenly above and below the Ref. Level. In addition, notice that the reference planes marking
the chord thickness adapted to the change in depth while maintaining their specified value. Verifying that the
entire model adapts to changes and making sure nothing “breaks” is the essence of flexing.

4 Enter 1' 6” for Depth, 0' 3” for Chord Thickness, 2' 6” for Center Chase Width, and click Apply.
Notice that the model adapts to all of the changes.
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Reset parameters
5 In the Family Types dialog box, reset the parameters back to their original values:
■

Enter 1' 0” for Depth.

■

Enter 0' 1 1/2” for Chord Thickness.

■

Enter 1' 4” for Center Chase Width.

■

Click Apply.

■

Click OK.

When working within the Family Editor, you should always flex the design after you add new elements or modify
the existing design in any way.
6 On the File menu, click Save.
7 Proceed to the next lesson, Adding Solid Geometry.

Adding Solid Geometry
In this lesson, you add the solid geometry using extrusions for the chords and trimmable plywood ends. After creating
the extrusions, you constrain them using a combination of locked alignments and labelled dimensions. After flexing
the design, you load the truss into a project to verify that it works as designed.

Creating Solid Extrusions
In this exercise, you create the top and bottom chords of the truss. After adding the chords, you align and lock their
position.

Dataset
Continue to use the dataset, Wood Floor Truss.rfa, that you saved at the end of the previous exercise.

Add chord extrusions
1 In the Project Browser, under Elevations, double-click Left.
2 Zoom in around the center of the truss design.
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3 On the Design Bar, click Solid Form ➤ Solid Extrusion.
4 In the Work Plane dialog box, click Name, select Reference Plane: Member Left, and click OK.
5 On the Design Bar, click Lines.
6 On the Options Bar, click

, and select Lock.

7 Select the four reference planes that border the top chord as shown.

Notice that the sketch lines are automatically locked to the reference planes.
8 On the Tools toolbar, click

.

When using the Trim tool, click the part of the line you want to keep.
9 Select perpendicular intersecting lines to create the top chord sketch as shown.

10 On the Design Bar, click Lines.
11 On the Options Bar, click

, and verify that Lock is selected.

12 Select the four reference planes that border the bottom chord as shown.
NOTE A warning dialog displays notifying you that there are overlapping lines. You can ignore this warning because
after you finish trimming, the lines will no longer overlap.
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13 On the Tools toolbar, click

.

14 Select perpendicular intersecting lines to create the bottom chord sketch as shown.

15 On the Design Bar, click Finish Sketch.
16 In the Project Browser, under 3D Views, double-click View 1.
Notice the chord extrusions and the symbolic line. The chords need to be aligned and locked to the correct reference
planes in order for them to flex with changes in the geometry.

17 On the File menu, click Save.
18 Proceed to the next exercise, Adding Constraints to the Solid Geometry.

Adding Constraints to the Solid Geometry
In this exercise, you add constraints to the chord extrusions and then flex the family to verify that it works as designed.

Dataset
Continue to use the dataset, Wood Floor Truss.rfa, that you saved at the end of the previous exercise.

Constrain the extrusion ends
1 In the Project Browser, under Elevations, double-click Front.
2 Enter SD; this is the keyboard shortcut for Shading with Edges.
This makes the chord extrusions more visible within the view.
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3 Select the chord extrusions.

4 Drag the right arrow control to the right until it snaps to the reference plane: Member Right, as shown.
Click the lock symbol to lock the extrusion edge to the reference plane.

5 Drag the left arrow control to the right until it snaps to the reference plane: Member Left, as shown.
Click the lock symbol to lock the extrusion edge to the reference plane.

Flex the design
6 Prepare the view for flexing in the same way you did during the flexing exercise. You’ll want to set up your screen
so you can see the model truss while the Family Types dialog box is open.
On the Design Bar, click Family Types.

7 In the Family Types dialog box, enter 20' 0” for Length, and click Apply.
Notice that the extrusions did not move or change their length. This is because the length dimension references
the extreme left and right reference planes, not the member right or member left reference planes. Therefore, you
must add a new constraint before flexing the length.
8 In the Family Types dialog box, enter 10' 0” for Length, click Apply, and click OK.
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Add a new dimension and constraint
9 On the Design Bar, click Dimension.
10 Add a dimension between the reference plane: Left and the reference plane: Member Left as shown.
Click the lock symbol to lock the dimension value.

11 Add a dimension between the reference plane: Right and the reference plane: Member Right as shown.
Click the lock symbol to lock the dimension value.

In this particular case, adding this constraint to the model has no impact on how it works within a project. This
is a two-point placement beam family that uses the member left and member right reference planes as the
determining extents of this component. Later in this lesson, you load this family into a project to test how it works
within a project environment.

Flex the length
12 On the Design Bar, click Family Types.
13 In the Family Types dialog box, enter 20' 0” for Length, and click Apply.
Notice that the extrusions adjusted to the change in length. This tells you that the constraints on the extrusion
ends are working.
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TIP If one of the extrusion ends did not adjust as expected, use the Align tool and add the constraint. Afterwards, flex
the model once again to make sure the fix works as expected.
14 Click OK.
In a later exercise, you add the web members. Therefore, you need a truss long enough to add web arrays and do
not need to return the truss back to its original length value.

Flex the chord width, depth, and thickness
15 In the Project Browser, under 3D Views, double-click View 1.
16 Enter SD for Shading with Edges.

17 On the Design Bar, click Family Types.
18 In the Family Types dialog box, specify the following:
■

Enter 2' 0” for Depth.

■

Enter 0' 8” for Chord Width.

■

Enter 0' 3” for Chord Thickness.
TIP When flexing, it is important to remember the original values so you can reset them afterwards. Therefore, try
picking a method, such as doubling, that allows you to easily return to the original values.

■

Click Apply.

The chords should adjust to each of the new values.
19 Specify the beam values shown below:
■

Enter 0' 11 7/8” for Depth.

■

Enter 0' 3 1/2” for Chord Width.

■

Enter 0' 1 1/2” for Chord Thickness.

■

Click Apply, and click OK.

20 On the File menu, click Save.
21 Proceed to the next exercise, Creating Additional Solid Geometry.

Creating Additional Solid Geometry
In this exercise, you add the extrusions for the truss ends and the center chase.
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Dataset
Continue to use the dataset, Wood Floor Truss.rfa, that you saved at the end of the previous exercise.

Add the center chase extrusions
1 In the Project Browser, under Floor Plans, double-click Ref. Level.
2 Zoom in on the center of the truss and select the model line that represents the beam stick symbol.
3 On the View Control Bar, click the Hide/Isolate control, and click Hide Object.
This will make it easier to sketch the center chase extrusions.
4 On the Design Bar, click Solid Form ➤ Solid Extrusion.
5 On the Design Bar, click Lines.
6 On the Options Bar, click

, and verify that Lock is selected.

7 Select the four reference planes that border the left, vertical member of the center chase as shown.

Notice that the sketch lines are automatically locked to the reference planes.
8 On the Tools toolbar, click

.

9 Select perpendicular intersecting lines to create the left, vertical member of the center chase sketch as shown.

10 On the Design Bar, click Lines.
11 On the Options Bar, click

, and verify that Lock is selected.

12 Select the four reference planes that border the right, vertical member of the center chase as shown.
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NOTE A warning dialog displays notifying you that there are overlapping lines. You can ignore this warning because
after you finish trimming, the lines will no longer overlap.

13 On the Tools toolbar, click

.

14 Select perpendicular intersecting lines to complete the center chase sketch as shown.

15 On the Design Bar, click Finish Sketch.
16 In the Project Browser, under Elevations, double-click Front.
17 Zoom in on the center chase.

Align and lock the new extrusions
18 On the Tools menu, click Align.
This next process is very important. The ends of the chase extrusions must be aligned and locked to the horizontal
reference planes coincident with the interior edges of the chords. Although you can align and lock extrusion to
extrusion, it is considered a best practice to align and lock to reference planes.
19 For the align-to reference, select the reference line on the top of the lower chord as shown.
You may need to press TAB to toggle the selection options.
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20 Click the bottom edge of one of the chase extrusions, and after the alignment, click the lock symbol to lock the
alignment.

21 Align the top edge of the chase extrusions with the reference line coincident with the lower edge of the upper
chord, and lock the alignment as shown.

22 On the Design Bar, click Modify.

Flex the center chase
23 On the Design Bar, click Family Types.
24 In the Family Types dialog box, specify the following:
■

Enter 1' 11 7/8” for Depth.

■

Enter 2' 4” for Center Chase Width.

■

Click Apply.

The truss should adapt to all the changes. If it does not, redo any problematic alignments and constraints.
25 In the Family Types dialog box, reset the values as follows:
■

Enter 0' 11 7/8” for Depth.

■

Enter 1' 4” for Center Chase Width.

■

Click Apply, and click OK.

Clean up the view
26 Zoom to Fit.
27 Clean up the view by moving the dimensions off to the side as shown.
This will make subsequent work much easier.
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Add the truss end extrusions
28 Select the Chord Thickness dimension in the lower-left corner as shown.

29 On the Options Bar, select Add Parameter for Label.
30 In the Parameter Properties dialog box, under Parameter Data, do the following:
■

Enter Trimmable End Length for Name.

■

Select Dimensions for Group parameter under.

■

Select Instance.

■

Click OK.

31 Select the Chord Thickness dimension in the lower-right corner of the view.
32 On the Options Bar, select Trimmable End Length for Label.
33 On the Design Bar, click Family Types.
34 In the Family Types dialog box, under Dimensions, enter 1' 0” for Trimmable End Length, click Apply, and click
OK.

Sketch the right end extrusion
35 In the Project Browser, under Elevations, double-click Right.
36 Zoom around the truss elements.
37 On the Design Bar, click Solid Form ➤ Solid Extrusion.
38 In the Work Plane dialog box, select Reference Plane: Member Right for Name, and click OK.
39 On the Design Bar, click Lines.
40 On the Options Bar, click

, and verify that Lock is selected.

41 On the upper chord, select the lower horizontal reference plane; on the lower chord, select the upper horizontal
reference plane. These two lines represent the upper and lower boundary of the sketch.
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42 On the Options Bar, enter 0' 0 3/4” for Offset.
43 Select the Center (Front/Back) reference plane twice to add a sketch line to each side as shown.

44 On the Tools toolbar, click

.

45 Select perpendicular intersecting lines to complete the end sketch as shown.
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46 On the Design Bar, click Extrusion Properties.
47 In the Element Properties dialog box, under Constraints, verify that 1' 0” is specified for the Extrusion End value,
and click OK.
48 On the Design Bar, click Finish Sketch.

Sketch the left end extrusion
49 In the Project Browser, under Elevations, double-click Left.
50 Zoom around the truss elements.
51 On the Design Bar, click Solid Form ➤ Solid Extrusion.
52 In the Work Plane dialog box, select Reference Plane: Member Left for Name, and click OK.
53 On the Design Bar, click Lines.
54 On the Options Bar, click

, and verify that Lock is selected.

55 On the upper chord, select the lower horizontal reference plane; on the lower chord, select the upper horizontal
reference plane. These two lines represent the upper and lower boundary of the sketch.
56 On the Options Bar, enter 0' 0 3/4” for Offset.
57 Select the Center (Front/Back) reference plane twice to add a sketch line to each side as shown.

58 On the Tools toolbar, click

.

59 Select perpendicular intersecting lines to complete the end sketch as shown.
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60 On the Design Bar, click Extrusion Properties.
61 In the Element Properties dialog box, under Constraints, specify -1' 0” for the Extrusion End value, and click OK.
NOTE This extrusion value must be negative in order to push the extrusion towards the center of the truss.
62 On the Design Bar, click Finish Sketch.

Add alignment constraints
63 In the Project Browser, under Elevations, double-click Front.

Although the truss ends line up with the reference planes controlling the length of the trimmable ends, they are
not aligned and locked to those reference planes and would not pass a flex test.
64 Zoom in on the left end of the truss.
65 On the Tools menu, click Align.
66 Select the Member Left reference plane as the align-to point.

67 Select the left edge of the left end extrusion, and lock the alignment.
68 Select the reference plane coincident with the right edge of the left end extrusion; this is the align-to point.
69 Select the right edge of the left end extrusion, and lock the alignment.
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70 Repeat the previous five steps for the right end of the truss. Make adjustments to account for the right side.
TIP When you finish the alignments, if you select the end extrusion, a lock displays on each side indicating the constraints
to the reference planes.
71 On the Design Bar, click Modify.

Flex the design
72 On the Design Bar, click Family Types.
73 In the Family Types dialog box, specify the following:
■

Enter 1' 11 7/8” for Depth.

■

Enter 2' 0” for Trimmable End Length.

■

Click Apply.

The truss should adapt to all the changes. If it does not, fix any problematic alignments and constraints.
74 In the Family Types dialog box, reset the values as follows:
■

Enter 0' 11 7/8” for Depth.

■

Enter 1' 0” for Trimmable End Length.

■

Click Apply, and click OK.

75 In the Project Browser, under 3D Views, double-click View 1.

76 Save the Family.
A new dataset is provided for you beginning with the next lesson. It is identical to the truss you have been designing.
If you are comfortable with your design, you can continue using it in the next lesson. If you have experienced any
errors or have deviated from the exercises in any way, you should close the file and begin with a fresh dataset.
77 Proceed to the next lesson, Testing the Family in a Project.

Testing the Family in a Project
In this lesson, you load the family into a project to test it in a real-world environment. After you load it into the project,
you add several beam instances and then modify the shape of the foundation to see how the beams adapt.
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Loading a Family into a Project
In this exercise, you load the truss family into a project that consists of foundation walls, a sill, and a rim joist.
NOTE Close any open families or projects. The truss family that you use in this lesson is identical to the truss you have created
in the previous exercises. Although you could continue using the previous family, it is recommended that you use the new
family in order to ensure consistency.

Datasets
Open the truss family
■

On the File menu, click Open.

■

In the left pane of the Open dialog box, click the Training Files icon.

■

Open the i_Wood Floor Truss_1.rfa file located in the Imperial\Families folder.

Open the project file
■

On the File menu, click Open.

■

In the left pane of the Open dialog box, click the Training Files icon.

■

Open the i_WWF1.rvt file located in the Imperial folder.

36 | Chapter 1 Parametric Component Design Techniques

Load the truss family into the project
1 On the Window menu, click i_Wood Floor Truss_1.rfa.
2 On the Design Bar, click Load into Projects.
The truss family is loaded directly into the only other open file. If you had multiple projects or families open, a
dialog box would have displayed asking for you to specify which projects you wanted to load the family into.
Notice that the project file is now active.
3 In the Project Browser, expand Families, expand Structural Framing, and notice that the Wood Floor Truss_1 family
has been loaded.
4 Proceed to the next exercise, Testing a Family Instance in a Project.

Testing a Family Instance in a Project
In this exercise, you add several instances of the truss family to the project, and then modify the project to see how
the beams adapt.

Dataset
Continue to use the datasets that you used in the previous exercise.

Add beams to project
1 In the Project Browser, expand Views, expand 3D Views, and double-click 3D - Southeast Isometric.
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This project consists of foundation walls, a slab, a wood sill, and a wood rim joist. The rim joist was added as a
beam; therefore, the truss family you loaded will interact with it as one beam does to another.
2 In the Project Browser, under Floor Plans, double-click Level 1.
3 On the Structural tab of the Design Bar, click Beam.
4 In the Type Selector, select i_Wood Floor Truss_1.
5 Using point-to-point insertion, add three vertical beams that snap to the rim joist at each end.
NOTE Do not be concerned with the exact location of the three beams. Try to make them approximately equidistant
as shown.

6 In the Project Browser, under 3D Views, double-click 3D - Southeast Isometric.
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Notice the wood truss sits on top of the sill and attaches to the rim joist as expected.
7 In the Project Browser, under Floor Plans, double-click Level 1.
8 Select Grid 2 and drag it downward until the walls form an approximate square.
NOTE Make sure you drag the grid line, not the wall or rim joist. You do not need to be precise; you are merely testing
the new floor truss to verify that it adapts to the changes.

9 In the Project Browser, under 3D Views, double-click 3D - Southeast Isometric.
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Notice the wood truss adjusted to the changes.
■

The truss ends remained constant and adapted to the new beam length.

■

The center chase remained the same width while remaining centered.

In the next lesson, you nest the web components into the truss and create an array that adapts to changes in length.
10 On the Edit menu, click Undo Drag.
This should return the project to its original dimension.
11 On the File menu, click Save as.
12 In the Save as dialog box, navigate to a folder of your choice and save the project with its existing name.
IMPORTANT Do not change the name of the family. The project and family need to interact based on a consistent file
name.

Edit a family from within a project
13 Select one of the wooden truss components.
14 On the Options Bar, click Edit Family.
15 When prompted to open the truss family for editing, click Yes.
Because the family is already open, the wood floor truss family becomes the active view.
16 Proceed to the next lesson, Working with Nested Subcomponents.

Working with Nested Subcomponents
In this lesson, you nest wood web members into the floor truss, and create a formula controlled array to fill in the truss.
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Adding a Nested Component
In this exercise, you nest two wooden web members into the truss. You then align and lock the web extents before
applying a formula-controlled array.

Dataset
Continue to use the datasets from the previous exercise.

Prepare the view for nesting
1 Make sure that i_Wood Floor Truss_1.rfa is the active file.
2 In the Project Browser, under Floor Plans, double-click Ref. Level.
3 Select the symbolic line in the center of the truss.
4 On the View Control Bar, click Hide/Isolate, and click Hide Object.
This will aid in the placement of the wood web.
5 On the File menu, click Load from Library ➤ Load Family.
■

In the left pane of the Open dialog box, click the Training Files icon.

■

Open the i_Wood_Web.rfa file located in the Imperial\Families folder.

This family is a single extrusion as shown. The extrusion is aligned and locked to invisible model lines that make
it easier to array within the truss. The geometry is driven by formula-based parameters that link to the host family.

Add two wood web components
6 On the Design Bar, click Component.
7 In the Type Selector, verify that i_Wood_Web: Wood Web is selected.
8 Add two instances of the wood web component as shown.
Place one wood web on each side of the center chase. Snap the center line of the web to the center reference plane
of the truss. Leave a slight gap between the chase and the web. This will make aligning the wood web easier.
IMPORTANT Make sure you snap the center line of the web components to the center reference line of the truss.
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9 On the Design Bar, click Modify.
10 In the Project Browser, under Elevations, double-click Front.
11 Place the cursor over the left wood web. Do not select it.

Notice the model lines that surround the web component; they are visible only when you place the cursor over
the component. In the following steps, you align the web panel using these lines rather than the extrusion edges.
Also notice that the depth of the web members needs to be changed. This will be accomplished in the next exercise
when you link the nested parameter with the host parameter.

Align the nested web components
12 Enter AL; this is the keyboard shortcut for Align.
You will align the left web component first.
13 For the align-to point, select the reference plane that is coincident with the left edge of the left center chase
extrusion.

14 Select the right vertical model line of the left web component as shown.

IMPORTANT Do not lock the alignment

15 Repeat the previous two steps to align the left edge of the right web component to the right edge of the center
chase as shown.
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Each of these web components represents the starting point of the web arrays that you add later in this lesson.
NOTE You do not have to align the top or bottom the web components because the height of the web members will
adapt to the truss height after you create and link the parameters in the next exercise. In addition, it is important to note
that you should avoid adding unnecessary constraints.
16 On the Design Bar, click Modify.

Add reference planes for array anchors
17 On the Design Bar, click Ref Plane.
18 Add two reference planes as shown. Place each reference plane just to the outside of the center of the web
components.

19 On the Tools menu, click Align.
The reference plane you added in the previous step represents half the web width. In the steps that follow, you
align the reference planes to the center of the web components.
20 Select the center of the left web component as the align-to point.

21 Select the reference plane that you added to the left of the web components center as shown.
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22 Click the lock to lock the reference plane to the centerline of the web component.

23 Repeat the previous two steps to align and lock the right web component and the reference plane as shown.

Dimension and label array anchors
24 On the Design Bar, click Dimension.
25 Add the following two dimensions:
■

Select the reference plane that you aligned to the center of the left web component.

■

Select the reference plane that is coincident with the right edge of the left web component and the outside
edge of the center chase.

■

Place the dimension as shown.

■

Select the reference plane that you aligned to the center of the right web component.

■

Select the reference plane that is coincident with the left edge of the right web component and the outside
edge of the center chase.

■

Place the dimension as shown.

44 | Chapter 1 Parametric Component Design Techniques

In the next exercise, you label these dimensions. You also add a formula to the parameter in order to maintain the
web position as the truss changes depth, length, or the width of the center chase.
26 On the Design Bar, click Modify.
27 On the File menu, click Save As.
28 In the Save As dialog box, navigate to the same directory in which you saved the project file and save this family
there with its current name.
29 Proceed to the next exercise, Creating Formula-controlled Parameters.

Creating Formula-controlled Parameters
In this exercise, you add new parameters to control the web components. You then link the nested web parameters to
the new host parameters.

Dataset
Continue to use the datasets that you saved in the previous exercise.

Create a new parameter for web depth
1 On the Design Bar, click Family Types.
2 In the Family Types dialog box, under Parameters, click Add.
3 In the Parameter Properties dialog box, under Parameter Data, do the following:
■

Enter WebDepth for Name.

■

Select Constraints for Group parameter under.

■

Select Common for Discipline.

■

Select Length for Type.

■

Select Type.

■

Click OK.

4 In the Family Types dialog box, under Constraints, enter Depth - (Chord Thickness * 2) for the WebDepth Formula.
TIP You can expand the width of the Family Types dialog box to facilitate typing within the formula field.
This formula ensures that the web depth will account for any changes in the chord thickness or truss depth.
NOTE Formulas are case sensitive. When you refer to another parameter within a formula, ensure you enter it exactly
as it is named.
5 Click OK.
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Link the nested component to the new parameter
6 Right-click the left web component, and click Properties.
7 In the Element Properties dialog box, click Edit/New.
8 In the Type Properties dialog box, under Other, click the button to the right of the WebHeight value.

9 In the Associate Family Parameter dialog box, select WebDepth, and click OK.
In the Type Parameter dialog box, notice that “= “displays within the WebHeight button.
10 In the Type Properties dialog box, click OK.
11 In the Element Properties dialog box, click OK.
12 On the Design Bar, click Modify.

Notice the web members are resized to fit more precisely between the chords. In addition, notice the center of each
nested web component is locked to the reference plane that bisects it.

Create new formula-controlled parameter for center chase
13 On the Design Bar, click Family Types.
14 In the Family Types dialog box, under Parameters, click Add.
15 In the Parameter Properties dialog box, under Parameter Data, do the following:
■

Enter CC for Name.
This parameter is primarily for convenience. It will use a formula to add the center chase width and the
thickness of the two bordering chords.

■

Select Other for Group parameter under.

■

Select Common for Discipline.

■

Select Length for Type.

■

Select Instance.

■

Click OK.

16 Under Other, enter Center Chase Width + (2*Chord Thickness) for CC Formula.
After you enter the formula, the resulting value is displayed as an inactive field.

Create WebArrayLength formula-controlled parameter
17 In the Family Types dialog box, under Parameters, click Add.
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18 In the Parameter Properties dialog box, under Parameter Data, do the following:
■

Enter WebArrayLength for Name.

■

Select Constraints for Group parameter under.

■

Select Common for Discipline.

■

Select Length for Type.

■

Select Instance.

■

Click OK.

19 Under Constraints, enter (Length - (CC+1))/2 for WebArrayLength Formula.
This formula subtracts the length of the center chase and its two bordering chords plus an additional 1' 0” before
dividing it in two to specify the length of each array. The additional 1' 0” is to account for the ends, which must
remain at least 0' 6” long.

Create WebArrayNum formula-controlled parameter
20 In the Family Types dialog box, under Parameters, click Add.
21 In the Parameter Properties dialog box, under Parameter Data, do the following:
■

Enter WebArrayNum for Name.

■

Select Constraints for Group parameter under.

■

Select Common for Discipline.

■

Select Integer for Type.

■

Select Instance.

■

Click OK.

22 Under Constraints, enter WebArrayLength/(2*WebDepth) for WebArrayNum Formula.
23 Click OK.

Add parameter to anchor web array
24 Select the dimension that refers to the midpoint of the left web as shown.

25 On the Options Bar, select Add parameter for Label.
26 In the Parameter Properties dialog box, under Parameter Data, do the following:
■

Enter Webhalflength for Name.

■

Select Constraints for Group parameter under.

■

Select Instance.

■

Click OK.

27 Select the dimension that refers to the midpoint of the right web.
28 On the Options Bar, select Webhalflength for Label.
29 On the Design Bar, click Modify.
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Add formula for Webhalflength
30 On the Design Bar, click Family Types.
31 Under Constraints, enter (WebArrayLength/WebArrayNum)/2 for Webhalflength Formula.
32 Click OK.
Notice the location of the web components has adapted to the formula.

Associate web component parameters
33 Right-click the left web component, and click Properties.
34 In the Element Properties dialog box, click Edit/New.
35 In the Type Properties dialog box, under Other, click the button to the right of the WebArrayLength value.
36 In the Associate Family Parameter dialog box, select WebArrayLength, and click OK.
In the Type Properties dialog box, the button next to the WebArrayLength value should have an equals sign within
it.
37 In the Type Properties dialog box, click OK.
38 In the Element Properties dialog box, click OK.
39 On the Design Bar, click Modify.
40 In the Project Browser, under 3D Views, double-click View 1.

Because you have added and constrained new components, it is very important that you flex the model to ensure
the nested components and the formulas that controls them work as expected. It is especially important to flex
the model before arraying the truss so that you don’t multiply any existing problems.
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Flex the design
41 Adjust the view so you can flex the truss while in the Family Types dialog box.
42 On the Design Bar, click Family Types.
43 In the Family Types dialog box, specify the following:
■

Enter 2' 11 7/8” for Depth.

■

Enter 0' 3” for Chord Thickness.

■

Click Apply.

The truss should adapt to all the changes. If it does not, fix any problematic alignments and constraints.

44 In the Family Types dialog box, reset the values as follows:
■

Enter 0' 11 7/8” for Depth.

■

Enter 0' 1 1/2” for Chord Thickness.

■

Click Apply, and click OK.

45 On the File menu, click Save.
46 Proceed to the next exercise, Arraying Nested Subcomponents.

Arraying Nested Subcomponents
In this exercise, you array the nested web components, add alignment constraints, and link the arrays to the
WebArrayNum parameter.

Dataset
Continue to use the datasets that you saved in the previous exercise.
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Array the left web component
1 In the Project Browser, under Elevations, double-click Front.
2 Select the nested web component left of the center chase.

3 On the Edit menu, click Array.
Creating an array requires two basic steps. First, you specify the move start point; then you specify the move end
point. You must use precision when arraying because any error is multiplied as the array grows.
4 On the Options Bar, specify the following:
■

Verify that Group and Associate is selected.

■

Enter 3 for Number.

■

Select 2nd for Move to.

■

Select Constrain.

5 Select the bottom-right corner of the nested web extrusion as the move start point. When picking the corner, use
the TAB key to toggle to the endpoint of the vertical model line within the nested family.

6 Select the bottom-left corner of the nested web extrusion as the move end point. When picking the corner, use
the TAB key to toggle to the endpoint of the vertical model line within the nested family.

7 Press ENTER to complete the array.
8 On the Design Bar, click Modify.

Array the right nested web component
9 Select the nested web component right of the center chase.
10 On the Edit menu, click Array.
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11 On the Options Bar, specify the following:
■

Verify that Group and Associate is selected.

■

Enter 3 for Number.

■

Select 2nd for Move to.

■

Select Constrain.

12 Select the bottom-left corner of the nested web extrusion as the move start point. When picking the corner, use
the TAB key to toggle to the endpoint of the vertical model line within the nested family.
13 Select the bottom-right corner of the nested web extrusion as the move end point. When picking the corner, use
the TAB key to toggle to the endpoint of the vertical model line within the nested family.

14 Press ENTER to complete the array.
15 On the Design Bar, click Modify.
16 Zoom out to view the truss.

Align and lock the arrays
17 Zoom in on the left array of web components.
18 On the Tools menu, click Align.
19 In the left array, place the cursor over the boundary between the two left web components until the reference
highlights, then select the line twice.

Because there are two overlapping lines at this location, you are aligning the two bordering web components to
each other.
20 Click the lock symbol to keep the web components locked at their edges.

21 Within the left array, align and lock the two right web components.
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22 Within the right array, align and lock the two boundaries between the three web components. Use the same
techniques as you did in the previous three steps.
NOTE This step is very important. If you do not lock the edges of the array, the web components overlap each other
when you change the depth of the truss.

Label the arrays
23 Select the middle web component of the left array.
24 Notice the array line displays above the components with the array value. Place the cursor over the array line as
shown and select it.

NOTE Do not select the array value.
25 On the Options Bar, select WebArrayNum for Label.
26 Select the middle web component of the right array.
27 Select the array line over the web components on the right.
28 On the Options Bar, select WebArrayNum for Label.
29 On the Design Bar, click Modify.
30 Zoom out until you can see the entire truss.

Notice the arrays appear to be too long. This is because earlier in the tutorial, you added a dimension to lock the
Member Left and Member Right reference plane to the outer Left and Right reference planes. The primary reason
for this was to allow for flexing the length.
31 Zoom around the left side of the truss.
32 Select the dimension between reference plane Left and Member Left as shown.
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33 Delete the dimension.
34 On the Tools menu, click Align.
35 Select the reference plane, Left, as the align-to point.
36 Select the reference plane, Member Left, and lock the alignment as shown.

Notice the end of the array still overlaps the trimmable end. You will fix this in later steps by changing the parameter
value.
NOTE With most beam families, you would not want to align and lock these two reference planes; however, in this case,
the wood floor truss normally sits on a sill bordering a rim joist. Therefore, this solution has little, if any, significant impact.
37 On the Design Bar, click Modify.
38 Zoom in around the right side of the truss.
39 Delete the dimension between reference plane Right and Member Right.
40 Align and lock reference plane Right and Member Right.

41 Zoom out until you can see the entire truss.
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Change trimmable end length value
42 On the Design Bar, click Family Types.
43 In the Family Types dialog box, under Dimensions, enter 0' 6” for Trimmable End Length.
44 Click Apply, and click OK.
Notice the web arrays fit within the truss without overlapping the ends.

Flex the design
45 In the Project Browser, under 3D Views, double-click View 1, and prepare the view for flexing.
46 On the Design Bar, click Family Types.
47 In the Family Types dialog box, specify the following:
■

Enter 2' 11 7/8” for Depth.

■

Enter 40' 0” for Length.

■

Enter 3' 0” for Center Chase Width.

■

Click Apply.

The truss should adapt to all the changes. If it does not, fix any problematic alignments and constraints.

TIP When flexing a complex model such as this, you should flex the model in as many ways as possible to verify it is
working correctly; however, for training and time purposes, these steps have been reduced.
48 In the Family Types dialog box, reset the values as follows:
■

Enter 0' 11 7/8” for Depth.

■

Enter 20' 0” for Length.

■

Enter 1' 4” for Center Chase Width.

■

Click Apply, and click OK.

You have completed the design of the primary components of the truss.
49 On the File menu, click Save.
50 Proceed to the next exercise, Reloading a Family into a Project.

Reloading a Family into a Project
In this exercise, you reload the truss family into the project. You then increase the distance between the foundation
walls to see how the truss adapts to the changes in length.
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Dataset
Continue to use the datasets that you saved in the previous exercise.
In addition to the truss family, the project, i_WWF1.rvt, should be open.

Reload the truss into the project.
1 Verify that the truss family is active and the 3D View, View 1, displays.
2 On the Design Bar, click Load into Projects.
3 In the Reload Family dialog box, select Override parameter values of existing types, and click Yes.
Notice the project file becomes active and the beam has updated with the latest changes.

4 In the Project Browser, under Floor Plans, double-click Level 1.
5 Drag Grid 2 downward until the shape of the building footprint is almost square.
6 In the Project Browser, under 3D Views, double-click 3D - Southeast Isometric.
Notice the truss has adapted to the changes.
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7 On the Edit menu, click Undo Drag.
8 Save and close the project file and the family file.
In the next lesson, you begin with a new dataset which is identical to both of these files.
9 Proceed to the next lesson, Applying Subcategories, Materials, and Parameters.

Applying Subcategories, Materials, and Parameters
In this lesson, you create and apply subcategories and materials. You then create a parameter to specifically control
material application.

Creating and Applying Subcategories
In this exercise, you create new subcategories within the truss family. You then reload the family into the project and
apply a material to the subcategory.

Datasets
■

On the File menu, click Open.

■

In the left pane of the Open dialog box, click the Training Files icon.

■

Open the i_WWF2.rvt file located in the Imperial folder.
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In this dataset, the truss was added to a beam system that occupies approximately half the building footprint. In
addition, four instances of the floor truss were added to the other end of the structure.

Apply Object Styles
1 Zoom in around beam system.
Notice no material has been applied to the truss. Within the family, the material values were set to By Category
by default.

2 On the Settings menu, click Object Styles.
3 In the Object Styles dialog box, verify that the Model Objects tab is selected, and expand the category Structural
Framing.
Notice that the Structural Framing category and all of the subcategories have no material value defined. In addition,
notice that the subcategories do not apply to the wood floor truss that you have designed.
4 On the Structural Framing category line, click in the material field until the button displays as shown.

5 Click the button that displays in the Structural Framing Material field.
6 In the Materials dialog box, click Wood - Pine for Name, and click OK.
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7 In the Object Styles dialog box, click OK.
Notice the Wood - Pine material has been applied to all Structural Framing components.

When you apply a material to the Structural Framing category, all subcomponents of that category are assigned
that material. If there was a metal beam in this building model, it would also have the wood material applied to
it. If you create subcategories as you design in the Family Editor, you have more control over component visibility
within a project.
8 On the Edit menu, click Undo Object Styles.

Create subcategories within the truss family
9 Select a truss that is not part of the beam system.
10 On the Options Bar, click Edit Family.
11 Click Yes to open the family for editing.
12 On the Settings menu, click Object Styles.
13 In the Object Styles dialog box, under Modify Subcategories, click New.
14 In the New Subcategory dialog box, enter Wood Floor Truss for Name, and click OK.

Apply material to subcategory
15 Click in the Material field for the Wood Floor Truss subcategory, and click the button to open the Materials dialog
box.
16 In the Materials dialog box, click Duplicate.
17 In the New Material dialog box, enter Wood Floor Truss, and click OK.
18 In the Materials dialog box, under AccuRender, click

.

19 In the Material Library dialog box, navigate to _accurender\Wood\Pine, Yellow, select Natural,No Gloss for Name,
and click OK.
20 In the Materials dialog box, click OK.
21 In the Object Styles dialog box, click OK.

Apply the subcategory to the truss components
22 Draw a pick box around the entire truss.
23 On the Options Bar, click

.

24 In the Filter dialog box, click Check None, select Other, and click OK.
Notice the chords and end extrusions remain selected.

58 | Chapter 1 Parametric Component Design Techniques

25 On the Options Bar, click

.

26 In the Element Properties dialog box, under Identity Data, select Wood Floor Truss for Subcategory, and click OK.
27 On the Design Bar, click Modify.

Apply a subcategory to the nested web components
28 Place the cursor over one of the arrayed web components, press TAB to toggle to the web component and click to
select it.
29 On the Options Bar, click Edit Family.
30 Click Yes to open the family for editing.
The web component family opens in a 3D view.
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31 On the Settings menu, click Object Styles.
32 In the Object Styles dialog box, under Modify Subcategories, click New.
33 In the New Subcategory dialog box, enter Wood Floor Truss - Webs for Name, and click OK.
By creating a separate subcategory for the web components, you can apply a different material to all web components
when using this truss within a project.
34 Click in the Material field for the Wood Floor Truss - Webs subcategory, and click the button to open the Materials
dialog box.
35 In the Materials dialog box, click Duplicate.
36 In the New Material dialog box, enter Wood Floor Truss - Webs, and click OK.
37 In the Materials dialog box, under AccuRender, click

.

38 In the Material Library dialog box, navigate to _accurender\Wood\Pine, Yellow, select Natural,No Gloss for Name,
and click OK.
39 In the Materials dialog box, click OK.
40 In the Object Styles dialog box, click OK.
41 Select the web extrusion.
42 On the Options Bar, click

.

43 In the Element Properties dialog box, under Identity Data, select Wood Floor Truss - Webs for Subcategory, and
click OK.

Reload web component into truss family
44 On the Design Bar, click Load into Projects.
45 In the Load into Projects dialog box, select i_Wood Floor Truss_1.rfa, and click OK.
46 In the Reload Family dialog box, select Override parameter values of existing types, and click Yes.
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Reload truss into project
47 On the Design Bar, click Load into Projects.
48 In the Load into Projects dialog box, select i_WWF2.rvt, and click OK.
49 In the Reload Family dialog box, select Override parameter values of existing types, and click Yes.
Notice the new object subcategory styles are applied to the truss components.

50 On the Settings menu, click Object Styles.
51 In the Object Styles dialog box, under Categories, expand Structural Framing.
Notice the two new subcategories are listed. You can change the style of only the wood truss components without
impacting other structural framing components.
52 Click OK.
53 On the View menu, click Visibility/Graphics.
54 In the Visibility Graphics dialog box, under Visibility, expand Structural Framing, clear Wood Floor Truss - Webs,
and click OK.
Notice the web extrusions not longer display; however, the stick symbols continue to display.

55 On the Edit menu, click Undo Visibility/Graphics.
56 On the File menu, click Save As.
57 In the Save as dialog box, navigate to a folder of your preference and save the project with the current name.
58 Proceed to the next exercise, Creating Material Parameters.
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Creating Material Parameters
In this exercise, you add a new material parameter that allows you to specify a material for each truss instance.

Dataset
Continue to use the dataset that you saved in the previous exercise.

Open truss family for editing
1 Select a truss that is not part of the beam system.
2 On the Options Bar, click Edit Family.
3 Click Yes to open the family for editing.

Create material parameter
4 On the Design Bar, click Family Types.
5 In the Family Types dialog box, under Parameters, click Add.
6 In the Parameter Properties dialog box, under Parameter Data, do the following:
■

Enter Floor Truss Material for Name.

■

Select Materials and Finishes for Group parameter under.

■

Select Common for Discipline.

■

Select Material for Type.

■

Select Instance.

■

Click OK.

7 In the Family Types dialog box, notice the default material is By Category.
In this case, do not assign a material to the parameter. When reloaded into a project, this component will continue
to use the material assigned to the subcategory by default. This material parameter allows you to assign a material
on an instance parameter.
8 Click OK.

Link truss extrusions to material parameter
9 Draw a pick box around the entire truss.
10 On the Options Bar, click

.

11 In the Filter dialog box, click Check None, select Structural Framing (Wood Floor Truss), and click OK.
Notice the chords and end extrusions remain selected.
12 On the Options Bar, click

.

13 In the Element Properties dialog box, under Materials and Finishes, click the button to the right of the Material
value field.
14 In the Associate Family Parameter dialog box, select Floor Truss Material, and click OK.
15 In the Element Properties dialog box, click OK.
16 Place the cursor over one of the web components, press TAB, and select the component.
17 On the Options Bar, click

.

18 In the Element Properties dialog box, click Edit/New.
19 In the Type Properties dialog box, under Other, click the button to the right of the WebMaterial value field.
20 In the Associate Family Parameter dialog box, select Floor Truss Material, and click OK.
21 Click OK twice.
22 On the Design Bar, click Modify.
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Reload truss into project
23 On the Design Bar, click Load into Projects.
24 In the Load into Projects dialog box, select i_WWF2.rvt, and click OK.
25 In the Reload Family dialog box, select Override parameter values of existing types, and click Yes.
Notice the appearance of the floor trusses has not changed.
26 Select a floor truss that is not part of the beam system.
27 On the Options Bar, click

.

28 In the Element Properties dialog box, under Materials and Finishes, click the Floor Truss Material field and click
the button that displays.
29 In the Materials dialog box, select Metal - Steel for Name, and click OK.
30 In the Element Properties dialog box, click OK.
31 On the Design Bar, click Modify.
Notice the material is applied only to the selected beam.

32 On the File menu, click Save.
33 On the File menu, click Close.
34 Close any open files.
You can save the open files if you wish. In the next lesson, a new dataset is supplied.
35 Proceed to the next lesson, Controlling Component Visibility.

Controlling Component Visibility
In this lesson, you add controls to specify the views in which each element displays and at what detail level.

Assigning Detail Level and View Controls
In this exercise, you designate the display of elements in specific views and at specific detail levels.
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Datasets
■

On the File menu, click Open.

■

In the left pane of the Open dialog box, click the Training Files icon.

■

Open the i_WWF3.rvt file located in the Imperial folder.

Change detail levels
1 On the View Control Bar, click Detail Level, and click Coarse.
Notice the rim joist no longer displays. However, notice the floor truss has not changed appearance, because you
have yet to assign a detail level to each of the elements within the truss family. Currently within the truss, all
elements display at all times in all views.

2 Select a floor truss.
3 On the Options Bar, click Edit Family.
4 Click Yes to open the family for editing.

Apply detail level controls to web components
5 Select a web component.
6 On the Options Bar, click Edit Family.
7 Click Yes to open the family for editing.
8 Select the web extrusion.
9 On the Options Bar, click Visibility.
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10 In the Family Element Visibility Settings dialog box, specify the following:
■

Under View Specific Display, clear Plan/RCP.

■

Clear Left/Right.

■

Under Detail Levels, clear Coarse.

■

Click OK.

11 On the Design Bar, click Load into Projects.
12 In the Load into Projects dialog box, select i_Wood Floor Truss_1.rfa, and click OK.
13 In the Reload Family dialog box, select Override parameter values of existing types, and click Yes.
Notice the appearance of the floor trusses has not changed.

Assign detail level to center chase extrusions
14 Select the center chase extrusions.
15 On the Options Bar, click Visibility.
16 In the Family Element Visibility Settings dialog box, specify the following:
■

Under View Specific Display, clear Plan/RCP.

■

Clear Left/Right.

■

Under Detail Levels, clear Coarse.

■

Click OK.

Assign detail level to truss ends
17 Select the end extrusions.
18 On the Options Bar, click Visibility.
19 In the Family Element Visibility Settings dialog box, specify the following:
■

Under View Specific Display, clear Plan/RCP.

■

Under Detail Levels, clear Coarse.

■

Click OK.

Assign detail level to truss chords
20 Select the truss chords.
21 On the Options Bar, click Visibility.
22 In the Family Element Visibility Settings dialog box, specify the following:
■

Under Detail Levels, clear Coarse.

■

Click OK.

Reload truss into project
23 On the Design Bar, click Load into Projects.
24 In the Load into Projects dialog box, select i_WWF3.rvt, and click OK.
25 In the Reload Family dialog box, select Override parameter values of existing types, and click Yes.
Notice that the floor truss solid geometry is not displayed.
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26 On the View Control Bar, click Detail Level, and click Medium.
Notice the floor truss solid geometry is displayed.
27 In the Project Browser, under Floor Plans, double-click Level 1.
28 On the View Control Bar, click Detail Level, and click Coarse.
Notice the symbolic representation of the beams.

29 On the File menu, click Save As.
30 In the Save As dialog box, navigate to your preferred location and save the project with the current name.
31 Proceed to the next lesson, Creating Component Types.

Creating Component Types
In this lesson, you create multiple floor truss types to speed up the design process when working in a project. In the
final exercise, you create a conditional formula that adjusts the truss depth based on the truss length.

Creating Multiple Component Types
In this exercise, you create multiple types for a 4x2 truss and a 3x2 truss. Although you can change the parameters of
a truss within a project, creating predefined types can speed up the design process.
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Open the truss family for editing
1 Select a floor truss.
2 On the Options Bar, click Edit Family.
3 Click Yes to open the family for editing.

Create new types
4 On the Design Bar, click Family Types.
5 In the Family Types dialog box, under Family Types, click New.
6 In the New dialog box, enter 4x2” for Name, and click OK.
7 In the Family Types dialog box, under Family Types, click New.
8 In the New dialog box, enter 3x2” for Name, and click OK.
9 In the Family Types dialog box, under Dimensions, enter 0' 2 1/2” for Chord Width, and click Apply.
Notice the chord changes width.
10 Select 4x2” for Name, and click Apply.
The truss returns to its original designed value.
NOTE When creating new components, create types for those most frequently used in your projects.
11 Click OK.
TIP You can also use new types to flex the model.

Load new types into the project
12 On the Design Bar, click Load into Projects.
13 In the Load into Projects dialog box, select i_WWF3.rvt, and click OK.
14 In the Reload Family dialog box, select Override parameter values of existing types, and click Yes.
15 On the Structural tab of the Design Bar, click Beam.
16 In the Type Selector, select 3x2”.
17 Add a beam in the center of the open space.
18 In the Type Selector, select 4x2”.
19 Add a beam next to the 3x2”.
20 On the Design Bar, click Modify.
21 In the Project Browser, under 3D Views, double-click 3D - Southeast Isometric.
Notice the two beam types.
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22 On the File menu, click Save.
23 Proceed to the final exercise, Creating Conditional Formulas.

Creating Conditional Formulas
In this exercise, you create a conditional formula that changes the depth automatically as the truss increases in length.

Open the truss for editing
1 Select a floor truss.
2 On the Options Bar, click Edit Family.
3 Click Yes to open the family for editing.

Adding a conditional formula
4 On the Design Bar, click Family Types.
You are going to enter a conditional formula that follows this basic rule:
IF ( <condition>, <result-if-true>, <result-if-false>)
5 In the Family Types dialog box, under Dimensions, enter the follow formula for Depth:
if(Length < 22', 0' 11 7/8", if(Length < 25', 1' 2", if(Length < 30', 1' 4", 1' 4")))
6 Click Apply.

Flex the design
7 In the Family Types dialog box, enter 27' for length, and click Apply.
Notice the truss depth increases.
8 In the Family Types dialog box, enter 20' for length, click Apply, and click OK.

Load the truss into the project
9 On the Design Bar, click Load into Projects.
10 In the Load into Projects dialog box, select i_WWF3.rvt, and click OK.
11 In the Reload Family dialog box, select Override parameter values of existing types, and click Yes.
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Test the conditional formula within a project
12 In the Project Browser, under Floor Plans, double-click Level 1.
13 Select Grid 2 and drag it downward until it is between 28'-30’ from Grid 1.
14 In the Project Browser, under 3D Views, double-click 3D - Southeast Isometric.
15 Notice the change in floor truss depth.
NOTE You would have to change the depth of the sill and rim joist to accommodate this change.
16 On the File menu, click Save.
IMPORTANT When you changed the width of the building footprint, you probably noticed a change in the amount
of time the view needed to regenerate. Regeneration time and overall performance can be affected by over-designed
families.
You have completed this tutorial.
17 Close any open files.
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